November, 2025
Incident Updates
RESOLVED
Service Announcement
Updates
- INVESTIGATING
We experienced temporary downtime on our website and billing system due to the implementation and testing of our new geo-replication system. Service has now been restored. Thank you for your patience and understanding.
- RESOLVED
Services have been restored, and we are actively monitoring to ensure full stability. Thank you for your understanding.
RESOLVED
Website Downtime Notice
Updates
- RESOLVED
Earlier today, our services were affected by a widespread Cloudflare outage. We’re happy to report that the issue has now been resolved, and all systems are operating normally again.
Thank you for your patience while the outage was addressed.
- INVESTIGATING
We are currently experiencing downtime due to a widespread Cloudflare outage affecting many online services, including ours. This issue is external to our systems, and we are monitoring the situation closely. Once Cloudflare restores full functionality, our services will resume automatically.